RetrOrangePi Official Forum
wifi not connecting - Printable Version

+- RetrOrangePi Official Forum (http://retrorangepi.download/forum)
+-- Forum: Latest Release (http://retrorangepi.download/forum/forumdisplay.php?fid=3)
+--- Forum: RetrOrangePi v4.3 (http://retrorangepi.download/forum/forumdisplay.php?fid=41)
+---- Forum: Retrostone2 (http://retrorangepi.download/forum/forumdisplay.php?fid=44)
+---- Thread: wifi not connecting (/showthread.php?tid=3329)



wifi not connecting - dotalxchan - 01-18-2020

Hi ,
I am having trouble connecting to wifi.. what can i do to help you debug this issue?


RE: wifi not connecting - arcadeshenanigans - 01-18-2020

It wasn't immediately evident to me as to how to do it but I did get the wifi going on mine eventually, maybe I can help? How far did you get?

Did you get a USB keyboard and mouse plugged in? When the wifi connectivity screen came up I mistakingly thought I might be able to navigate it with the D-pad and buttons but that isn't the case, it definitely needed keyboard and mouse to proceed.


RE: wifi not connecting - alexkidd - 01-18-2020

Guys, please check the readme 1st thread
http://orangepi.club/showthread.php?tid=3316

"To use the builtin wifi, go into desktop mode from RetroPie-RetrOrangePi-Armbian Desktop and run "sudo nmtui" from a terminal session and choose the access point. Onscreen keyboard should work, although an usb mouse is recommended."

Dpad should work, i'll check that out


RE: wifi not connecting - dotalxchan - 01-21-2020

thanks for the help.. i was trying to configure using retropie setup script via ssh .. using "sudo nmtui" worked


RE: wifi not connecting - dotalxchan - 01-21-2020

reflash system with new image posted...
I went into armbian desktop mode.
I used terminal emulator and typed/used "sudo nmtui" . I was able to add my wifi information. However, I am not able to activate the wifi afterwards.


RE: wifi not connecting - alexkidd - 01-21-2020

Wifi is disabled by default.

From http://orangepi.club/showthread.php?tid=3330 :
"Whenever you need internet, run Enable from RetroPie - RetrOrangePi - Wifi submenu. It should autoconnect to your access point. Select Connect if you havent set a connection yet (must have usb keyboard to type password)"

It's not even necessary to go into desktop mode


RE: wifi not connecting - Daniel - 01-22-2020

Wifi connects without problems the first time but after a restart the connection is gone and I no longer have an IP address.


RE: wifi not connecting - alexkidd - 01-22-2020

(01-21-2020, 08:48 PM)alexkidd Wrote: Wifi is disabled by default.

From http://orangepi.club/showthread.php?tid=3330 :
"Whenever you need internet, run Enable from RetroPie - RetrOrangePi - Wifi submenu. It should autoconnect to your access point. Select Connect if you havent set a connection yet (must have usb keyboard to type password)"