RetrOrangePi Official Forum
Problems with screen and performance - Printable Version

+- RetrOrangePi Official Forum (http://retrorangepi.download/forum)
+-- Forum: Latest Release (http://retrorangepi.download/forum/forumdisplay.php?fid=3)
+--- Forum: RetrOrangePi v4.3 (http://retrorangepi.download/forum/forumdisplay.php?fid=41)
+---- Forum: Retrostone2 (http://retrorangepi.download/forum/forumdisplay.php?fid=44)
+---- Thread: Problems with screen and performance (/showthread.php?tid=3371)



Problems with screen and performance - Arcaden - 01-30-2020

First of all, GameBoy Advance is very unplayable. I've tested with several games, the most telling being Sonic Advance 3. Constant slowdown and stuttering. I have to set frameskip to 1 to even play at normal speed some of the time. My raspberry Pi Zero can play GBA perfectly, not to mention RetroStone 1, so I'm confused as to why it doesn't work on this device. 

And this is a general issue that applies to every game, the colors on the screen are too low saturation specifically for red and blue. Here's an image showing the RetroStone 2 on the left and my PC on the right, displaying the same game. 

https://imgur.com/a/tOgg49G

Is there any way to adjust this?


RE: Problems with screen and performance - alexkidd - 01-30-2020

GBA seems full speed to me with the lr-gpsp core
Switch it after launching a game

About colors, I'll check later if there is any setting.


RE: Problems with screen and performance - Arcaden - 01-31-2020

(01-30-2020, 06:11 PM)alexkidd Wrote: GBA seems full speed to me with the lr-gpsp core
Switch it after launching a game

About colors, I'll check later if there is any setting.

Thank you, I went into more detail about the colors in my other post but no one commented on it :/

Edit: OH ALSO, the low power light has been on all of the time, even after just coming off the charger.

(01-30-2020, 06:11 PM)alexkidd Wrote: GBA seems full speed to me with the lr-gpsp core
Switch it after launching a game

About colors, I'll check later if there is any setting.

lr-gpsp crashes every time I try to launch any GBA game.


RE: Problems with screen and performance - alexkidd - 01-31-2020

You need to copy GBA bios
https://github.com/RetroPie/RetroPie-Setup/wiki/BIOS


RE: Problems with screen and performance - Arcaden - 01-31-2020

(01-31-2020, 01:39 AM)alexkidd Wrote: You need to copy GBA bios
https://github.com/RetroPie/RetroPie-Setup/wiki/BIOS

Oh yeah!! I forgot that I had to do this on the GPi Case to get it to work. Thanks!!


RE: Problems with screen and performance - tofos - 02-02-2020

Hello there,

First of all, thanks for your invaluable work, alexkidd!

I have the same issues as Arcade. Not only on GBA, GBC also seems to stutter. Here's some games I've tried:

GBA (I've tried all the cores, none is perfect, the best one stutters every second or so, depending on what's going on in the game)
Pokémon Fire Red
Pokemon Lead Green
Advance Wars
Advance Wars 2

GBC (same as GBA, I've tried every core an it stutters every few seconds even if I'm doing nothing in the game)
Pokémon Yellow
Legend Of Zelda - Link's Awakening

I've also tried GB and SNES and those works flawlessly so far.

Edit: I've just checked Pokémon Blue on GB and it also stutters every few seconds. But I've noticed one thing. I think that background music on the menu of Retrorangepi also stutters every few seconds, so maybe it's not the emulator cores problem?

Edit 2: Yup, I'm 100% sure that music in the main menu stutters.


RE: Problems with screen and performance - wackko_lefin - 02-02-2020

(01-31-2020, 01:29 AM)Arcaden Wrote:
(01-30-2020, 06:11 PM)alexkidd Wrote: GBA seems full speed to me with the lr-gpsp core
Switch it after launching a game

About colors, I'll check later if there is any setting.

Thank you, I went into more detail about the colors in my other post but no one commented on it :/

Edit: OH ALSO, the low power light has been on all of the time, even after just coming off the charger.

(01-30-2020, 06:11 PM)alexkidd Wrote: GBA seems full speed to me with the lr-gpsp core
Switch it after launching a game

About colors, I'll check later if there is any setting.

lr-gpsp crashes every time I try to launch any GBA game.

Hi, same issue for me, even after a full charge, low battery led always on...
Guess it's may be a hardware issue, so I'll try to post on 8bitcraft forum for this...

Edit : done the post for the hardware part here


RE: Problems with screen and performance - Arcaden - 02-03-2020

(02-02-2020, 07:59 PM)tofos Wrote: Hello there,

First of all, thanks for your invaluable work, alexkidd!

I have the same issues as Arcade. Not only on GBA, GBC also seems to stutter. Here's some games I've tried:

GBA (I've tried all the cores, none is perfect, the best one stutters every second or so, depending on what's going on in the game)
Pokémon Fire Red
Pokemon Lead Green
Advance Wars
Advance Wars 2

GBC (same as GBA, I've tried every core an it stutters every few seconds even if I'm doing nothing in the game)
Pokémon Yellow
Legend Of Zelda - Link's Awakening

I've also tried GB and SNES and those works flawlessly so far.

Edit: I've just checked Pokémon Blue on GB and it also stutters every few seconds. But I've noticed one thing. I think that background music on the menu of Retrorangepi also stutters every few seconds, so maybe it's not the emulator cores problem?

Edit 2: Yup, I'm 100% sure that music in the main menu stutters.

Have you tried disabling wifi? That fixes most of my issues, though there's still occasional stutter everywhere.


RE: Problems with screen and performance - alexkidd - 02-03-2020

For now, need to disable both wifi and background music otherwise annoying stuttering and terminal ALSA errors
To be fixed on upcoming update