Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[OPi Plus 2E] Install RetrOrangePi on eMMC
Hi every one,
I'll try here to explain you how to install RetrOrangePi on the eMMC for OP PC Plus 2E (should be the same thing for every card that has eMMC on it).

English is not my first language so do not hesitate to correct me if I made some mistakes.

First things first, read the installation instructions here to install it on the microSD card

Then, when you're on EmulationStation, go to the menu "Retropie" (Configuration) 

[Image: IMG-20190918-230341.jpg]

Select RetroOrange Pi.

[Image: IMG-20190918-230350.jpg]

Here select the first item : Armbian Config.

[Image: IMG-20190918-230358.jpg]

You should see something like that. Select the first item "System and security setting"

[Image: IMG-20190918-230412.jpg]

You arrive on this screen. Again, select the first item "Install to / update boot loader"

[Image: IMG-20190918-230421.jpg]

One more time select the first item on the next screen : Boot from eMMC - system on eMMC

[Image: IMG-20190918-230434.jpg]

Last step is to accept the script will erase the eMMC. Let the script do it and "Voilà". When the Pi is off you can pull the TF Card, it should boot on the eMMC.

[Image: IMG-20190918-230441.jpg]

Hope this thred is usefull for someone.
Now for the step 2 : How to have our games on the SD card ?

It's easy.

In the Retropie menu, Select RETRORANGEPI.

On the Desktop copy the folder /home/pi/RetroPie/ on your SD Card
Something like :
cp -R /home/pi/RetroPie/* /dev/mmcblk0p1/

Open a terminal then enter : 

sudo nano /etc/rc.local

And In this file insert before "exit 0" : 

sudo mount -o nonempty /dev/mmcblk0p1 /home/pi/RetroPie

Then do Ctrl + x and tape y to save the file

Reboot, enjoy !

NB : Sometimes changes on rc.local won't work the first reboot, but after a couple time it's work Smile
NB2 : Your SDCard must not be ext4 formated. Mine is a 128Gb so i used exFAT

Thanks for the info, I always wondered how to do that.

Hi @Remylenain,

I have a question, what would be the folder structure do I need in the SD?

/home/pie/Retropie/(the folders for each emulator) or

/home/pie/Retropie/roms/(the folders for each emulator)

Thanks for your help.

Hi ZeroHager,

Sorry for the late answer.

I forgot a step in my previous reply : copy the directory of Retropie at the root of the SD card.

The structure on my SD is something like this : 

├── BIOS/
│   └──  Your bios here
├── music/
│   └──  Your music here (there are some as default)
├── retropiemenu/ (don't touch something if you don't know what you do)
│   ├── icons/
│   │   └── Some icons.png
│   ├── RetrOrangePi/
│   │   └── Some files and folders
│   └── some files.rp
├── roms/
│   ├── gameboy/
│   │   └── Your GameBoy ROMs here
│   ├── megadrive/
│   │   └── Your megadrive ROMs here
│   ├── psx/
│   │   └── Your Playstation ROMs here
│   └── ...
└── splashscreens/
   ├── bootsnd.ogg
   ├── README.txt
   └── splash.jpg
Hi @Remylenain,

Thanks and no problem for the late answer, didn't work for me Sad this is what I did,

1. Retrorange version 4.2 (4.3 didn't wor for me, I installed but didn't work, I only get reboot after reboot, maybe this is the problem (the version) )

2. I used the command "cp -R /home/pi/RetroPie/* /dev/mmcblk0p1/" and this is what I got, /dev/mmcblk0p1 not a directory, but in the image (under window) you can see /dev/mmcblk0p1 is the path for the SD 29.72 GB

01.jpg image (I don't know but can't put the image here)

3. so I used the comand "cp -R /home/pi/RetroPie/* /media/pi/a lot of numbers and letters" (the right window), didn't work neither, permission denied

02.jpg image (I don't know but can't put the image here)

4. My rc.local file

rc local.jpg image (I don't know but can't put the image here)

so, I have an image of my SD when I run retrorange from the SD, so I put the SD into my PC and copied the files manually, put the SD into the orangepi, restart several times but nothing happend.

I supposed I'am doing something wrong because I have the error /dev/mmcblk0p1 is not a directory.

Can you please give me another hand.

Thansk for your time and the post.

Attached Files Thumbnail(s)
V4.3 was updated yesterday. Try new version from official site
Hi and sorry Sad ,

Still not working, now I have this

1. Retrorange 4.3.

2. Install Retrorange in the eMMC, no problem.

3. Format the SD on my PC to ext4 and named "SD".

4. Runned this on terminal "cp -R /home/pi/RetroPie/* /dev/mmcblk0p1/", persist the error "/dev/mmcblk0p1 is not a directory", so I runned this "cp -R /home/pi/RetroPie/* /media/pi/SD" and copied the files without a problem.

5. Modify rc.local and add this line before "exit 0", "sudo mount -o nonempty /dev/mmcblk0p1 /home/pi/RetroPie", no problem with this.

6. Restart the orangepi and had boot problems, seems like if the orange pi has a SD always boot from the SD first, didn't find the files so didn't boot at all.

7. Pull out the SD, boot from eMMC and on emulation station put in the SD again and then press F4, and try to runned this "sudo mount -o nonempty /dev/mmcblk0p1 /home/pi/RetroPie" and had an error "wrong fs type, bad option or bad superblock" so tried this "sudo mount /dev/mmcblk0p1 /home/pi/RetroPie" and had no problem, but I don't know if it's ok. So Modify the rc.local again with "sudo mount /dev/mmcblk0p1 /home/pi/RetroPie" but still not working, same boot problems, seems to boot from SD and not from eMMC.

Maybe I'm missing something.

At this point I'm thinking to give up and continue booting from the SD.

Thanks again for your time.

(10-05-2019, 09:53 AM)alexkidd Wrote: V4.3 was updated yesterday. Try new version from official site

Thanks @alexkidd.
Humm sorry, my skills are limited, all I explained here was did with Alexkidd help  Blush

But i'll try to help you.
I'm on the 4.3 version, on the 4.2 there is an automatic script to do that if I remember it well.

I pretty sure my SD card is FAT32 formated, I can check it right know, but i'll do it tomorow.
I'll copy here my rc.local too.

When I look my armbianEnv.txt (in /boot/) I see 

So I think it's for that your board try to boot on the SD card.

It's only some guess, like I said my skills are limited (and my english too, I hope I didn't write too weird things Confused )
My SDCard is formated exFAT Wink

Possibly Related Threads…
Thread Author Replies Views Last Post
  RetrorangePi v4.3 - Winplus - How to change language? kkgamewolf 2 927 04-14-2022, 08:57 PM
Last Post: Teboraers
  Retrorangepi 3 LTS davmika 3 1,069 03-27-2022, 08:09 PM
Last Post: gleam2003
Question RetrOrangePi v5 LucasAugusto 4 1,600 02-03-2022, 06:09 PM
Last Post: gleam2003
  RetrOrangePi sources? rauli 1 1,818 02-08-2021, 08:39 AM
Last Post: alexkidd
  I can only boot from EMMC Drew Nucci 1 1,359 11-27-2020, 02:48 AM
Last Post: Drew Nucci
  OrangePi PC Plus - Setup Install on EMMC roms on SD yolkfolk 8 7,998 11-27-2020, 01:04 AM
Last Post: Drew Nucci
Sad How can I run games on USB in RetrOrangePi 4.3? Serj94x 3 3,337 09-26-2020, 08:11 PM
Last Post: phantomroach
  is retrorangepi dead Broos-E 19 10,208 09-22-2020, 10:34 AM
Last Post: Broos-E
Sad Need Help about RetrOrangePi on Pi One phelias 1 1,833 06-19-2020, 01:20 PM
Last Post: alexkidd
  problem update retrorangepi mathv86 2 2,317 06-18-2020, 04:48 PM
Last Post: alexkidd

Forum Jump:

Users browsing this thread: 1 Guest(s)