Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Loads GBA rom, music plays, but screen returns to menu with music still playing
Hey, I upgraded to the recent bugfixes version via ethernet and the procedures recently posted (thanks for the console commands to do so!). 
I have been noticing the music isn't as distorted after the upgrade and it does seem much snappier on startup.

However, this may be unrelated to any recent upgrade - but I'm noticing a few of my GBA roms will load, and when it looks like they start, they return to the emulator menu. The weird thing is the music of the last game to fail or work (doesn't matter) will continue playing while I'm in the main menu or when the unit boots next. 

I've mostly been working through my Game Boy Advance collection, so this is where I've noticed it most - but also saw it happen on a few of the Amiga Roms, and SNES Roms I've loaded. I figured I'd check to see if Game Boy Advance is fully vetted and supported yet, since I ran with some of the more popular ones for GBA, including Zelda - Minish Cap and Super Mario Advance 4. Not to say all games fail, but maybe 10% of those I've tried in GBA so far. I have been enjoying Fire Emblem  Sacred Stones recently as an example of working ROM so you've got a positive example too. 

Update: Two more fails on start - minor games I'm sure we've all been dying to use: Hello Kitty Happy Party Pals (lol) and Inspector Gadget Advanced :-) . Hello Kitty didn't make it to the small splash screen indicating press a button to configure prior to booting. Inspector Gadget did, but then returned to the GBA rom selection menu right away. Since that's the last one I tried, the music persists now in the menu. Off to work now though, although maybe I'll let the music run through and rock out a bit to some polyphonic sounds while I make a lunch. Hope this helps troubleshoot a bit.

Update2: Okay it may be all GBA games, so something must happen that can upset even working roms at some point. I tried powering on Fire Emblem Sacred Stones just to confirm, and that also exhibited the weird case of returning to the main menu after trying to start it, so something has thrown the stability off a bit. I was able to play that one just fine a week ago, then I took the recent bugfix update and added more games, so those are the only recent changes I've done. I checked to make sure the battery wasn't low, since I rebooted and it couldn't stay on. But, with it plugged in and charging it's failing to start a few formerly working roms now, so I'm not sure what's up - possibly it needs to charge longer, but wanted to relay status before I head out.
Add gba_bios.bin to RetroPie/BIOS folder
(02-13-2020, 04:32 PM)alexkidd Wrote: Add gba_bios.bin to RetroPie/BIOS folder

Will do and note results - however, how do you add gba_bios.bin to the RetroPie/BIOS folder?

/home/pi/RetroPie/BIOS/gba_bios.bin - what is the root url? Best way to add?

I was able to play most of these gba files prior to yesterday - I added about 20 more recently, but don't recall doing anything to remove the gba bios in the first place. I guess I assumed they were included so didn't think about the need to do so.
Add Bios the same way you add ROMs
Previous emulator didn't require a bios, the current does
(02-14-2020, 12:40 AM)alexkidd Wrote: Add Bios the same way you add ROMs
Previous emulator didn't require a bios, the current does

Okay, it took me awhile to figure out where to actually download the bios, since that wiki page spoke a bit more to experienced users.
I found this site informative in helping:

This worked like a charm! Problem solved - just powered up Final Fantasy Tactics Advance, Super Mario Advance - no issues.

Also, didn't realize how easy Samba share was with this - just type in \\RETRORANGEPI and it's far faster to transfer, making the USB route cumbersome in comparison.

we dont allow ROMS or BIOS links in the forum, as it can bring us legal issues. Sorry. Your post was edited

Possibly Related Threads…
Thread Author Replies Views Last Post
  Screen rotation Jackie Lee 4 823 06-17-2020, 05:21 PM
Last Post: alexkidd
  New RS2: 2 LEDs on but black screen. Madrayken 2 625 06-16-2020, 09:45 PM
Last Post: Madrayken
  Splash Screen Not working Weird_1diot 5 1,552 06-16-2020, 08:20 PM
Last Post: 999Nocturne
  Any way to change RetroRangePi logo on loading screen rolle 6 1,709 06-11-2020, 03:42 PM
Last Post: rolle
  Retrostone 2 Playstation just goes into Main Menu WeLoveHandball 10 2,787 05-19-2020, 08:50 PM
Last Post: alexkidd
  Background Music Weird_1diot 2 788 04-07-2020, 12:43 AM
Last Post: alexkidd
  Doom controller on menu Osommome 0 549 03-19-2020, 02:24 PM
Last Post: Osommome
  How play with screen no cut ? Tøm 6 1,615 03-09-2020, 08:07 PM
Last Post: alexkidd
  Some video’s of me playing some emulators Marco Verhoeven 4 2,364 02-21-2020, 01:28 AM
Last Post: alexkidd
  LCD screen does not work after disabling HDMI. Valden 2 938 02-20-2020, 01:18 PM
Last Post: Valden

Forum Jump:

Users browsing this thread: 1 Guest(s)