Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Retrostone 2 Playstation just goes into Main Menu
#1
HeySmile

I am sorry If this is a very dumb question but i tried my best to fix it with other threads in this forum. Unfortunately it doesnt work out:/

-Yes i have the bios and now i can start the game and see the playstation startscreen with sound
-I use .iso
-RetroorangePi 4.3 (RetrOrangePi 4.3 FULL)

My problem: If I start a playstaion game I see the starting screen with sound and end up in a Main menu where i can choose between memory card and CD player. I cant choose one of these settings and switch around but i cant start the game.

What I tried:
1. I deleted and copied all .iso again, but it happens again
Source: http://orangepi.club/showthread.php?tid=3411

2. I went to the settings and tried to delete all lines with pcsx_rearmed. Unfortunately there was no single line with this expression:/
Source: http://orangepi.club/showthread.php?tid=3440

3. I downloaded this file: "wget http://retrorangepi.download/bugfix2.tar.gz"  
Did it on a stick and connected to my Retrostone2.
a)there is no file called the specific file in step 5.
b)i also dont get where to save the zip and unpack it and i also have no idea what to do with the extractes files...
c)step 6: what is "sudo poweroff"? xD

Source: http://orangepi.club/showthread.php?tid=...27#pid9427

Can somebody help me out?
And I am sorry again if I just didnt saw another thread with this problem or maybe i wasnt just able to do it the right way:/ I am new in using forums, i hope I didnt do something the wrong way.

Thanks for inputsSmile
WeLoveHandball
Reply
#2
Hey !

Had pretty much the same problem, fixed by using files under .bin / .cue file
Still, some gameslaunch (Fighting Force, Crash bandicoot) and some does not like FF VII (crashes when launches a new game)
Reply
#3
Psx runs perfect with the correct bios, I use games in chd v5 and I have no problems, with FFVII neither.

Of course, I had to change the core replacing it with another because it suffered some black screen.

Also to say that this machine is not powerful for all games, games like Thunderforce V, Colin Mc rae, soul blade, ... they work very badly.
Reply
#4
Hey @Skatboo and @CISKO

@Skatboo: Okay i converted it into bin and tried it. If I just copy the .cue file, it wont appear in the emulatorstaion. When I also copy the .bin it appears and I can start it. After starting I get a Black screen...which games are working on your emulationstaion?

@CISKO: okay cool, so which bios do u use? I use SCPH1001.bin but i see there are many others here: https://github.com/RetroPie/RetroPie-Set...ystation-1
I have no idea which one to use...? Or can I use all of them and the machine chooses the right or or is this not recommandable and the emulationstation gets confused?

Thanks for helping me outBig Grin

EDIT: I use ntsc and PAL games. I think this also affects the bios. So can I use multiple BIOS? I now tried a few of them and i also got a blackscreen after the playstaionstartingscreen with music:/
Reply
#5
You need both the .bin and .cue files, that's probably why you're getting a black screen.

If you're playing both PAL and NTSC games you'll need two different sets of BIOS ai would think. I would advise sticking with just one ROMset anyway.

Also to answer one of your earlier questions, "sudo poweroff" is a command to turn off your system. You should open up the command line from the Retrostone and input the commands there, it's easier than trying to download the file on a stick.
Reply
#6
press a button on the lauching dialog to enable the option "Launch with verbose logging".
You can then check the full log from RetroPie - Runcommand Log option
Reply
#7
Hi,

I have the same problem with PSX emulator on my retrostone 2, I own Retrostone 1 and everything was OK with PSX.

Black screen without playstation intro for some games (Arc the Lad Collection for example), return to menu for others (Castlevania: Symphony of the Night for example).

I got all SCPH Bios, most of games are BIN + CUE, everything was working perfectly on RS1.
Any ideas?

PS : Thanks Alex for your great job!
Reply
#8
I'm able to run it fine

my setup

BIOS
pi@RetrOrangePi:~$ ls -l RetroPie/BIOS
-rwxrwxr-x  1 pi pi 524288 May 13 19:41 SCPH1001.BIN

ROM
pi@RetrOrangePi:~$ ls -l RetroPie/roms/psx/
-rwxrwxr-x 1 pi pi  44676240 May 13 19:37 'Castlevania - Symphony of the Night (USA) (Track 2).bin'
-rwxrwxr-x 1 pi pi 538655040 May 13 19:41 'Castlevania - Symphony of the Night (USA).bin'
-rwxrwxr-x 1 pi pi      252 May 13 19:41 'Castlevania - Symphony of the Night (USA).cue'
-rw-rw-r-- 1 pi pi    131072 May 13 19:43 'Castlevania - Symphony of the Night (USA).srm'

Retroarch core configuration file:
http://www.retrorangepi.download/retroar...ptions.cfg

copy to /opt/retropie/configs/all/  or configs/all if through network shared folders

[Image: IMG_20200513_170438.jpg]


edit: Retrostone 1 is only similar in name. Everything else is different: CPU, OS, kernel, emulator, core, default configurations.
edit2: you can also edit /opt/retropie/configs/all/retroarch-core-options.cfg and remove all pcsx_reamed entries
Reply
#9
Thanks Alex!
It works great now!
Here we go for a new tip!
Reply
#10
HeySmile It now mostly worked out after diffrent variations of settings. I can play most of the NTSC games. I just took the recommanded bios versions from the emulator and added a few others just to test. https://github.com/RetroPie/RetroPie-Set...disc-games

Questions
1. Is there a way to play PAL versions too? sometimes I can start the game but even with an added PAL bios it doesnt work:/ and yes i know, the emulator is optimized por NTSC bios and games, but is there no possibility?
2. Legend of mana or legend of dragoon dont work (NTSC), I have no idea why....does somebody know how to work it out?
3.I have some games with multiple CDs and I also saw an tutorial how to play these games. to be honest i dont understand how to do it xD has anybody an esier version to help me out? haha I am sorry
Source: https://github.com/RetroPie/RetroPie-Set...disc-games

Thanks for your feedbackSmile
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  OS NAND Retrostone pro bouboulover 5 1,485 10-19-2021, 08:50 PM
Last Post: D86592
  NEW FIRMWARE FOR RETROSTONE 2 PLS! retrofan 7 661 09-29-2021, 06:15 AM
Last Post: nicke85
  Retrostone not booting - black screen Kayno 6 1,262 03-20-2021, 09:06 PM
Last Post: GingeR13
  Download Link Dead [404 Not found] and Giving some love from us to Retrostone 2 Metainferno 2 1,117 01-26-2021, 09:31 PM
Last Post: alexkidd
  Retrostone 2 Pro with M.2 Sata SSD. maicoalvim 1 924 10-18-2020, 09:43 AM
Last Post: 999Nocturne
  Joystick for Playstation 1 (lr-pcsx-rearmed) rolle 0 872 07-26-2020, 12:36 PM
Last Post: rolle
  Configuring 8Bitdo SF30 Pro BT with Retrostone 2 Jodibam 4 1,946 06-11-2020, 02:14 PM
Last Post: Jodibam
  Playstation Problem timespawn 14 6,339 06-05-2020, 03:11 PM
Last Post: timespawn
Thumbs Down Retrostone 2 wifi and psx memory card Krempo 3 1,919 06-05-2020, 03:01 PM
Last Post: timespawn
  HDMI on Dosbox with Retrostone 2 Jodibam 2 1,272 06-03-2020, 04:42 PM
Last Post: Jodibam

Forum Jump:


Users browsing this thread: 1 Guest(s)